Forum


Replies: 4   Views: 2364
Problem with addchart and "showtable" parameter in version 7.5
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by jari.heinonen  · 26-01-2018 - 14:18

Hi there,

We would like to move on from phpdocx v. 7.0 to v. 7.5 and have been lately converting chart data to the new structure required by the 7.5 version. But we have problems with addChart "showTable" parameter. It just does not work. Setting it to true (true, 1 or '1') makes no difference. We have also tried examples with the same results. There was no problem with the 7.0 version but now the table of chart data does not appear under any bar chart. Weirdly enough, one can easily open a resulting docx file and manually set the option to true for any chart.

Hope that someone could help us with this issue.

Regards, Jari

Posted by admin  · 26-01-2018 - 17:30

Hello,

We're checking the issue (displaying the table of values in charts). Which package are you using? classic or namespaces?

Regards.

Posted by jari.heinonen  · 29-01-2018 - 10:38

We're using Classic

Posted by admin  · 29-01-2018 - 11:08

Hello,

The dev team has checked the issue and it appears by a wrong lowercase in a variable.

Please edit the classesCreateBarChart.inc file, and around line 226, you'll find this:

if (!empty($this->_showtable)) {

Please change it by:

if (!empty($this->_showTable)) {

and try again. The table should appear correctly after this change.

Although we're going to upload a new package with this fix, these are the files that need the same change: CreateAreaChart.inc, CreateBarChart.inc, CreateLineChart.inc, CreateRadarChart.inc and CreateSurfaceChart.inc.

Our apologies for any inconvenience.

Regards.

Posted by jari.heinonen  · 29-01-2018 - 15:07

Hi

Thank you a lot. That really helped!

Best Regards, Jari