Replies: 10   Views: 4427
Pdf converstion failed
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by unicorn  · 30-10-2013 - 07:41

I am trying to run the pdf conversion of php_docx_pro and nothing happens

after checking the problem I got:

root@cp [~]# ls -l /home/afik/public_html/public_docx/temp/tempDocX_526d4afbd97ab.docx

-rw-r--r--. 1 afik afik 138833 Oct 27 19:18 /home/afik/public_html/public_docx/temp/tempDocX_526d4afbd97ab.docx

root@cp [~]# /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter /I /home/afik/public_html/public_docx/temp/tempDocX_526d4afbd97ab.docx /O /home/afik/public_html/public_docx/temp/tempOdt_526d4afbdb4cf.odt 

-bash: /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter: Permission denied

root@cp [~]# ls -l /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter

-rw-r--r--. 1 afik afik 7859157 Oct  1 08:39 /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter

root@cp [~]# chmod a+x !$

chmod a+x /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter

root@cp [~]# /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter /I /home/afik/public_html/public_docx/temp/tempDocX_526d4afbd97ab.docx /O /home/afik/public_html/public_docx/temp/tempOdt_526d4afbdb4cf.odt 

Bus error (core dumped)

please help

Posted by jorgelj  · 30-10-2013 - 08:52


This is the error from your output:

-bash: /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter: Permission denied

Please check read, write and execute access to OdfConverter and destination folder.


Posted by unicorn  · 31-10-2013 - 20:21

You will see that I found the error and fixed it with chmod command.

Then I executed it again and I got BUS ERROR CORE DUMP

Posted by jorgelj  · 01-11-2013 - 19:57


Please run the OdfConverter standalone, without parameters:

$ /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter

And paste the output. What version of PHPDocX are you using?, package and release version please. And OS?.


Posted by unicorn  · 05-11-2013 - 20:39

same result:

root@cp [~]# /home/afik/public_html/phpdocx_pro_conv/classes/../lib/OdfConverter 

Bus error (core dumped)

root@cp [~]# 




root@cp [~]# uname -a

Linux 2.6.32-358.18.1.el6.x86_64 #1 SMP Wed Aug 28 17:19:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

root@cp [~]# 


root@cp [~]# cat /etc/redhat-release

CentOS release 6.4 (Final)

root@cp [~]# 


Hope this helps.



Posted by jorgelj  · 06-11-2013 - 09:07


You need to download the lastest version of PHPDocX that includes OdfConverter for 64bits. Previous versions only included OdfConverter for 32bits.

Please download the new version and run again the OdfConverter standalone:

$ lib/OdfConverter/64/OdfConverter


Posted by unicorn  · 06-11-2013 - 19:14

how do I download the latest version without paying again?

beside, I baught it only a month ago. isn't it late enoghth?

Posted by jorgelj  · 07-11-2013 - 09:15


You don't need to pay again. You just need to open MYPHPDOCX after login and you'll can download the new version.


Posted by unicorn  · 15-11-2013 - 10:08

I finally got the 64 bit version. I had to fix permission again but still it is crashing now with segment violation:

root@cp [64]# ./OdfConverter 

Segmentation fault


Output of strace shows it crashes at load time:

root@cp [64]# strace ./OdfConverter 

execve("./OdfConverter", ["./OdfConverter"], [/* 33 vars */]) = -1 EFAULT (Bad address)

--- SIGSEGV (Segmentation fault) @ 0 (0) ---

+++ killed by SIGSEGV +++




Posted by jorgelj  · 18-11-2013 - 09:13


Please contact us: We'll need to check your server.