Forum


Replies: 13   Views: 4455
Unable to generate pdf, even tried phpdocx sample script
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by oapl  · 22-07-2014 - 14:38

Hi, Unable to generate PDF, even tried PHPDocx sample script still does not produce anything? i am using corporate version.

Posted by admin  · 22-07-2014 - 15:38

Hello, Please check the available documentation on this website. And enable the debug option when you invoke the transformación. It'll return all the info. Regards.

Posted by oapl  · 23-07-2014 - 16:45

HI tried log but no luck, could it be to do with open office installation ? its not giving any error etc. regards

Posted by tonioseiler  · 24-07-2014 - 00:47

Same Problem here. Debug output is: [INFO][C:\tmp\tempDocX_53d056130142c.docx] Converting tempDocX_53d056130142c.docx into tempOdt_53d0561305ca6.odt [INFO][C:\tmp\tempDocX_53d056130142c.docx] Conversion succeeded [INFO][C:\tmp\tempDocX_53d056130142c.docx] Total conversion time: 00:00:02.5326819 Done. But I cannot find the odt file and the pdf is also not there. By teh way: I am on a windows plattform.

Posted by admin  · 24-07-2014 - 12:00

Hello, You need to enable the debug mode in the transformDocument method, not in phpdocx config. After it run the example using the CLI mode. Regards.

Posted by oapl  · 26-07-2014 - 01:34

its giving following error: /****/phpdocx_pro_new/classes/../lib/OdfConverter/64/OdfConverter: error while loading shared libraries: libexif.so.12: cannot open shared object file: No such file or directory

Posted by oapl  · 26-07-2014 - 03:08

HI, even generatePDF is not working anymore with pro version? is it to do with server? can you please suggest?

Posted by oapl  · 26-07-2014 - 03:18

it seems it works fine with small text but not with longer or bigger document? Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 7680 bytes) in /XXX/pdf/include/text_frame_reflower.cls.php(381) : runtime-created function on line 1 is there any patch for this?

Posted by oapl  · 26-07-2014 - 03:23

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 75 bytes) in /XXX/pdf/include/frame.cls.php on line 519

Posted by oapl  · 29-07-2014 - 22:54

any thoughts on this admin?

Posted by admin  · 30-07-2014 - 13:23

Hello, That error: Fatal error: Allowed memory size comes from the PHP config, you need to increase the available memory. About this error: error while loading shared libraries: libexif.so.12 you need to install that library in your OS to be able to run OdfConverter. If you see any other missing library, please install it too. Regards.

Posted by oapl  · 01-08-2014 - 11:11

thanks for reply. library is installed. It converts fine when tried SSH. but in PHP it does not return any error and no pdf. Only Docx is generate not the pdf? AdvanceTransform i am using.

Posted by oapl  · 02-08-2014 - 03:00

I am getting this error ** (OdfConverterTestStatic.exe:1628): CRITICAL **: _wapi_shm_file_open: shared file [/var/www/.wapi/shared_data-mail.XXX.com-Linux-x86_64-328-12-0] open error: No such file or directory ** (OdfConverterTestStatic.exe:1628): CRITICAL **: _wapi_shm_attach: shared file [/var/www/.wapi/shared_data-mail.XXX.com-Linux-x86_64-328-12-0] open error ** ERROR **: file shared.c: line 349 (shm_semaphores_init): assertion failed: (tmp_shared != NULL) aborting... ** (process:1628): WARNING (recursed) **: Thread (nil) may have been prematurely finalized Stacktrace: ** (process:1628): WARNING (recursed) **: Thread (nil) may have been prematurely finalized Native stacktrace: /XXX/phpdocx_pro_new/classes/../lib/OdfConverter/64/OdfConverter() [0x44ca20] /lib64/libpthread.so.0() [0x348e60f500]

Posted by oapl  · 02-08-2014 - 23:49

created folder .wapi and it worked. thanks for help