Forum


Replies: 2   Views: 2227
Pdf conversion doens't work after apache update.
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by criptos  · 07-06-2017 - 22:42

Ok, here is the issue. 

I made wwrun to have a useful shell 

usermod -s /bin/bash wwwrun 

Excecuted /opt/libreoffice/program/soffice and said it required java, 

Installed java.

Reexecuted the program with --headless. 

And then wwwrun was able to run soffice. 

But when i tried by the web, then ti didn't worked. 

I reseted the server and apache worked correctly. 

The issue was, I was reseting the apache wiht apache2ctl restart instead of "system wide restart" with systemctl restart apache. 

That was the issue..