Forum


Replies: 7   Views: 537
I can't convert a docx file to pdf file in a microsoft server
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by alberto.cortes@ezzing.com  · 23-07-2019 - 09:05

Hi,

I'm trying to convert a docx file to pdf file in a Microsoft Server,

I've installed Microsoft Office 2013 in the server,

I've a Microsoft Server because some docx files cannot be converted by LibreOffice.

 

Why not?

Because there are some docx documents that have many designs, objects, etc.

when I convert a docx file to PDF with LibreOffice the pdf output file doesn't looks like 100% to the original docx file for this reason I'm trying to use Microsoft Office for getting a convertion 100%.

 

I've a small API where we need to send the file to convert, everything looks like good except when I use te "transformFormat" method from "MSWordInterface" in that's moment I always get same error:

"""

com_exception

<b>Source:</b> Microsoft Word<br/><b>Description:</b> El elemento del conjunto solicitado no existe.

at MSWordInterface->transformFormat('C:\\388.docx', 'C:\\388.pdf')

"""

I've tried everything but doesn't work,

Could you help me, please?