Replies: 4   Views: 1185
Using transformdocument
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by net7  · 29-09-2021 - 14:11

I've exactly the same problem reported here:


..and here:


...and I tried everything was suggested by Admin...with no success.

When I call the function I put the entire path: 

$docx->transformDocument(/Users/zoba-mac/Sites/laravel/storm-laravel/storage/app/n7dg_results/75/c_tracking_badge.docx, /Users/zoba-mac/Sites/laravel/storm-laravel/storage/app/n7dg_results/75/c_tracking_badge.pdf)

I even launched the script on "examples/FormatConversion/transformDocument/libreoffice"...and I got the same error output: "Warning: rename(./transformDocument_libreoffice_1.pdf,transformDocument_libreoffice_1.pdf): No such file or directory in /Users/zoba-mac/Downloads/Storm/SW/phpdocx-premium-10.0-ns/Classes/Phpdocx/Transform/TransformDocAdvLibreOffice.php on line 174"

My /home/.config is 777.

What else is wrong?