Forum


Replies: 3   Views: 3558
Replacetemplatevariablebyhtml
Topic closed:
Please note this is an old forum thread. Information in this post may be out-to-date and/or erroneous.
Every phpdocx version includes new features and improvements. Previously unsupported features may have been added to newer releases, or past issues may have been corrected.
We encourage you to download the current phpdocx version and check the Documentation available.

Posted by wnha  · 13-11-2012 - 20:17

I've just bought PHPDOCX PRO+ version and got the error message like this below:

Fatal error: Uncaught exception 'Exception' with message 'Issue reading: http://www.2mdc.com/PHPDOCX/example.html' in C:\wamp\htdocs\phpdocx_pro\lib\dompdfParser\include\parserhtml.cls.php:309 Stack trace: #0 C:\wamp\htdocs\phpdocx_pro\lib\dompdfParser\include\parserhtml.cls.php(784): PARSERHTML->load_html_file('http://www.2mdc...') #1 C:\wamp\htdocs\phpdocx_pro\classes\HTML2WordML.inc(488): PARSERHTML->getDompdfTree('http://www.2mdc...', true, 'capa_bg_bottom') #2 C:\wamp\htdocs\phpdocx_pro\classes\HTML2WordML.inc(460): HTML2WordML->renderDompdf('http://www.2mdc...', true, 'capa_bg_bottom') #3 C:\wamp\htdocs\phpdocx_pro\classes\CreateDocx.inc(4815): HTML2WordML->render('http://www.2mdc...', Array) #4 C:\wamp\htdocs\phpdocx_pro\examples\easy\replaceTemplateVariableByHTML.php(22): CreateDocx->replaceTemplateVariableByHTML('CHUNK_1', 'block', 'http://www.2mdc...', Array) #5 {main} thrown in C:\wamp\htdocs\phpdocx_pro\lib\dompdfParser\include\parserhtml.cls.php on line 309

I have excuted /phpdocx_pro/examples/easy/replaceTemplateVariableByHTML.php without changes. Other functions except replaceTemplateVariableByHTML() works well. (It must be not an installation issue.)

Please help. :)

Posted by admin  · 11-04-2013 - 12:13

Hello,

Seems you're unable to get the content of that URL. Do you have access to Internet in your server?.

Regards.

Posted by wnha  · 11-04-2013 - 12:13

Hello,

I fixed it. It needs to change php.ini option.

allow_url_fopen = On

Thank you for your reply